Results 1 to 5 of 5
  1. #1

    Missing user pages fail to return HTTP 404

    Missing user pages on Weasyl are returning HTTP 200 rather than the expected HTTP 404.

    This has the side-effect of causing mistyped URLs to linger around in history, adding to the clutter.

    To reproduce, just visit a missing user page such as https://weasyl.com/~auseraccounthatdoesntexist and notice that the status code returned is not 404.

  2. #2
    My username is 404 now and I was a active member!

    https://www.weasyl.com/Lunoris

  3. #3
    Quote Originally Posted by Lunoris View Post
    My username is 404 now and I was a active member!

    https://www.weasyl.com/Lunoris
    You need to prepend your username with a tilde (~).

  4. #4
    Okay, I see now. Still can't log in thought.

  5.   This is the last staff post in this thread.   #5
    [Logic is Erratic] Taw's Avatar
    Weasyl
    Taw
    Join Date
    Jun 2012
    Location
    Canada
    Gender
    Male
    Posts
    821
    Sorry for the delays, holidays were crazy busy for me.

    Quote Originally Posted by Lunoris View Post
    Okay, I see now. Still can't log in thought.
    If you are having issues logging in, please attempt to reset your password with the following URL:
    https://www.weasyl.com/forgotpassword

    After attempting to reset it, if you are still having issues, please contact us via our support email, support@weasyl.com and we'll look into it further.

    As for the HTTP 200 instead of 400, I'll give the devs a heads up on this topic.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •