I still use IMO.
I just have absolutely refused to update it, ever since they added that thing where you need to register an account with them to use it.
I don't know what version I have. Still works, though.