PDA

View Full Version : [SITE] Images appearing on front page despite option selected to not show.



JohnV
08-09-2015, 12:13 AM
I recently submitted items into a folder I created for scraps to not be put on the front page. I setup the options of the folder that the images would not give notifications to follower nor show on Weasyl's front page before uploading them. I uploaded the images, with the "Scraps" folder being their destination but they still appeared on Weasyl's front page. I have found all three I submitted listed on the front page when browsing submissions. I am not certain if I did something wrong when submitting them or ran into an issue. I did a quick search of the forum for anything similar and came up with no other possible topics. Was hoping to add them discretely for personal reasons.

Lagos
08-09-2015, 07:28 PM
I uploaded the images, with the "Scraps" folder being their destination but they still appeared on Weasyl's front page. I have found all three I submitted listed on the front page when browsing submissions.

Hello, JohnV. Thank you for the bug report.

I'm having trouble reproducing this issue. Just to be clear: When you say that you saw them while browsing submissions, do you mean that you saw them on the index of the mainsite (i.e. https://www.weasyl.com/ ) or while paging through recent submissions (i.e. https://www.weasyl.com/search )?

The setting in question only prevents the former. I can see how this could be counter-intuitive, however.

JohnV
08-09-2015, 10:02 PM
Lagos,

They were appearing on the main site page, the folder was selected to not generate notifications or post to the front page. The folder in question has an id within the address of 79552 and is labeled "Scraps and Such". It only has three submissions that all are visible on the front page.

Lagos
08-10-2015, 10:50 PM
Hm. Interesting. The settings on the folder look correct and I don't see anything wrong with the code -- in particular, the images don't show up on your profile page and that uses essentially the same logic. Two questions:

1) If you upload another image to this folder, does the problem happen again?
2) Were the settings on the folder set before or after uploading the images?

If the folder's settings were changed after the images were added to it, the images could have appeared on the main index and been cached for a little while. I know this is probably not the case, but I'm exhausting explanations.

JohnV
08-16-2015, 01:27 PM
The settings for the folder were set before the images were submitted. Submitted a new one and it didn't appear on the front page. Think it might be a misunderstanding on my part, I was thinking they wouldn't display at all even when browsing all items.