PDA

View Full Version : Xchat program



demonicbolt
07-03-2014, 07:39 AM
Hi, this is gonna sound stupid but please bare with me here. After the IRC announcement for Weasyl, I thought 'ok, I'll get one of these and try it out'. Yeah, turns out I can't work this program to save my life. I tried to join the room following the instructions, but I get a message saying I need ActiveTCL, so I installed that, and it still doesn't work, saying I need it 'in the PATH' or something. Anybody know what this means? How do you fix it? I cant figure this out to save my life

Thank you
DemonicBolt

Noxid
07-03-2014, 06:00 PM
I don't use Xchat myself, but some googling turned up this (http://forum.xchat.org/viewtopic.php?t=4329), which says you need to make sure you got the 32-bit version and restart xchat after installing it.
As far as putting the bin folder on the PATH, well that's a hassle and a half but if you wanna know how to do that then the basic steps are:
press the windows key
type "system env" then select the option that comes up saying "edit system environment variables"
in the window that comes up, press "Environment Variables" button near the bottom
in "System variables" (bottom section), scroll down till you find the PATH variable
Select it, then press "Edit..." to bring up an input window
Now, find where you installed ActiveTCL, then the "bin" folder in that directory
go into the bin folder, then click the navigation bar at the top of the file explorer to get the filepath. Copy that to the clipboard.
Now, back at the environment variable input, scroll all the way to the end and if there isn't a semicolon, add one. Then paste the path you copied right after it.
Press ok, ok, apply/ok, then start Xchat again
and if that doesnt work, then it's screwed up


OR,
you could try a different IRC client. IceChat (http://www.icechat.net/site/downloads/?category=3)is what I use and it works alright on windows out-of-the-box, it's not setup to use SSL by default I think though so before connecting you'll have to right-click the server and select "Edit Server...", then go to Extra Settings and tick "Connect with SSL".

Good luck.

Saiko
07-03-2014, 06:12 PM
On Windows? Open your control panel and search for "path." Click "Edit the system environment variables." This should open the System Properties window. Under the Advanced tab, click "Environment Variables." Under System Variables, click the line for Path and click "Edit..." At the end of the Variable Value, add a semicolon and type in the file path to ActiveTCL. It will likely be something like C:\Program Files (x86)\ActiveTCL\folder-containing-the-file\, but you'll have to find the correct location on your own because it's specific to your machine.

What this will do is tell Windows to look in that folder, along with all the other ones in the Path, when it needs to run something.

Before you do this, however, please make sure you've set up XChat properly. To my knowledge, you shouldn't need TCL unless you want to use particular plugins. Make sure you download XChat from here (http://xchat.org/windows/), run the installer with its default options, and launch the program. This will open the Network List. Type in the three nicknames you want (e.g. demonicbolt, demonicbolt_, and demonicbolt__), a user name, and a "real" name. Note that these are not yet associated with an account, and anyone can technically be using them, thus the backup choices.

Under the Networks section, click "Add" and name the new network "Weasyl" or something. Click "Edit..." and under "Servers for <network name you typed>" click the "newserver/6667." Click the "Edit" button and change it to "irc.weasyl.com/6697". Under Connecting, make sure "Use SSL for all the servers on this network" and "Accept invalid SSL certificate" are checked. Note that these two boxes are specific to Weasyl. Different servers may or may not need these.

Close the edit window, make sure Weasyl is selected, and click "Connect." After it connects, look on the left to see if you have "WZLNet" with a subheading of "#weasyl." If you do not, type "/join #weasyl"; and you'll be there. :3

SHORT VERSION THAT I SUSPECT WAS THE ROOT PROBLEM:
When you create the new network for Weasyl in the Network List and are customizing it, make sure both "Use SSL for all the servers on this network" and "Accept invalid SSL certificate" are checked.

demonicbolt
07-04-2014, 12:23 PM
Issues resolved :D Thank you fellow Weasyl-goers!